Rapid7 Vulnerability & Exploit Database

RHSA-2003:042: Updated squirrelmail packages close cross-site scripting vulnerabilities

Back to Search

RHSA-2003:042: Updated squirrelmail packages close cross-site scripting vulnerabilities

Severity
7
CVSS
(AV:N/AC:M/Au:N/C:P/I:P/A:P)
Published
12/18/2002
Created
07/25/2018
Added
10/28/2005
Modified
07/04/2017

Description

Updated squirrelmail packages are now available for Red Hat Linux.

SquirrelMail is a webmail package written in PHP. Two vulnerabilities have been found that affect versions of SquirrelMail shipped with Red Hat Linux 8.0. A cross-site scripting (XSS) vulnerability in Squirrelmail version 1.2.10 and earlier allows remote attackers to execute script as other web users via read_body.php. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CAN-2002-1341 to this issue. An incomplete fix for a cross-site scripting vulnerability in SquirrelMail 1.2.8 calls the strip_tags function on the PHP_SELF value but does not save the result back to that variable, leaving it open to cross-site scripting attacks. (CAN-2002-1276) All users of Squirrelmail are advised to upgrade to these packages based on SquirrelMail version 1.2.10 which contain a backported patch to fix these issues.

Solution(s)

  • redhat-upgrade-squirrelmail

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;