Rapid7 Vulnerability & Exploit Database

RHSA-2003:261: Updated pam_smb packages fix remote buffer overflow.

Back to Search

RHSA-2003:261: Updated pam_smb packages fix remote buffer overflow.

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
10/20/2003
Created
07/25/2018
Added
10/28/2005
Modified
07/04/2017

Description

Updated pam_smb packages are now available which fix a security vulnerability (buffer overflow).

The pam_smb module is a pluggable authentication module (PAM) used to authenticate users using an external Server Message Block (SMB) server. A buffer overflow vulnerability has been found that affects unpatched versions of pam_smb up to and including 1.1.6. On systems that use pam_smb and are configured to authenticate a remotely accessible service, an attacker can exploit this bug and remotely execute arbitrary code. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CAN-2003-0686 to this issue. Red Hat Linux versions 7.2, 7.3, 8.0, and 9 ship with versions of pam_smb that are vulnerable to this issue, however pam_smb is not enabled by default. Users of pam_smb are advised to upgrade to these erratum packages, which contain a patch to version 1.1.6 to correct this issue. Red Hat would like to thank Dave Airlie of the Samba team for notifying us of this issue.

Solution(s)

  • redhat-upgrade-pam_smb

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;