Rapid7 Vulnerability & Exploit Database

RHSA-2003:405: Updated apache packages fix minor security vulnerability

Back to Search

RHSA-2003:405: Updated apache packages fix minor security vulnerability

Severity
7
CVSS
(AV:L/AC:L/Au:N/C:C/I:C/A:C)
Published
11/03/2003
Created
07/25/2018
Added
10/28/2005
Modified
07/04/2017

Description

Updated Apache packages that fix a minor security issue are now available for Red Hat Linux 7.1, 7.2, and 7.3.

The Apache HTTP server is a powerful, full-featured, efficient, and freely-available Web server. An issue in the handling of regular expressions from configuration files was discovered in releases of the Apache HTTP Server version 1.3 prior to 1.3.29. To exploit this issue an attacker would need to have the ability to write to Apache configuration files such as .htaccess or httpd.conf. A carefully-crafted configuration file can cause an exploitable buffer overflow and would allow the attacker to execute arbitrary code in the context of the server (in default configurations as the 'apache' user). The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CAN-2003-0542 to this issue. All users of the Apache HTTP Web Server are advised to upgrade to the applicable errata packages, which contain back-ported fixes correcting this issue.

Solution(s)

  • redhat-upgrade-apache
  • redhat-upgrade-apache-devel
  • redhat-upgrade-apache-manual

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;