Rapid7 Vulnerability & Exploit Database

RHSA-2004:090: libxml2 security update

Back to Search

RHSA-2004:090: libxml2 security update

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
03/15/2004
Created
07/25/2018
Added
10/28/2005
Modified
07/12/2017

Description

Updated libxml2 packages that fix an overflow when parsing remote resources are now available.

libxml2 is a library for manipulating XML files. Yuuichi Teranishi discovered a flaw in libxml2 versions prior to 2.6.6. When fetching a remote resource via FTP or HTTP, libxml2 uses special parsing routines. These routines can overflow a buffer if passed a very long URL. If an attacker is able to find an application using libxml2 that parses remote resources and allows them to influence the URL, then this flaw could be used to execute arbitrary code. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CAN-2004-0110 to this issue. All users are advised to upgrade to these updated packages, which contain a backported fix and are not vulnerable to this issue.

Solution(s)

  • redhat-upgrade-libxml2
  • redhat-upgrade-libxml2-devel
  • redhat-upgrade-libxml2-python

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;