Rapid7 Vulnerability & Exploit Database

RHSA-2007:0542: mcstrans security and bug fix update

Back to Search

RHSA-2007:0542: mcstrans security and bug fix update

Severity
2
CVSS
(AV:L/AC:M/Au:N/C:N/I:N/A:P)
Published
11/09/2007
Created
07/25/2018
Added
03/10/2008
Modified
07/04/2017

Description

An updated mcstrans package that fixes a security issue and a bug is now available. This update has been rated as having low security impact by the Red Hat Security Response Team.

mcstrans is the translation daemon used on SELinux machines to translate program context into human readable form. An algorithmic complexity weakness was found in the way the mcstrans daemon handled ranges of compartments in sensitivity labels. A local user could trigger this flaw causing mctransd to temporarily stop responding to other requests; a partial denial of service. (CVE-2007-4570) This update also fixes a problem where the mcstrans daemon was preventing SSH connections into an SELinux box, that was running a Multi-Level Security (MLS) Policy with multiple categories. Users of mcstrans are advised to upgrade to this updated package, which resolves this issue.

Solution(s)

  • redhat-upgrade-mcstrans

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;