Rapid7 Vulnerability & Exploit Database

RHSA-2008:0243: java-1.4.2-bea security update

Back to Search

RHSA-2008:0243: java-1.4.2-bea security update

Severity
7
CVSS
(AV:N/AC:M/Au:N/C:P/I:P/A:P)
Published
03/06/2008
Created
07/25/2018
Added
05/21/2008
Modified
07/04/2017

Description

The BEA WebLogic JRockit 1.4.2_16 JRE and SDK contains BEA WebLogic JRockitVirtual Machine 1.4.2_16 and is certified for the Java 2 Platform, StandardEdition, v1.4.2.A flaw was found in the Java XSLT processing classes. An untrustedapplication or applet could cause a denial of service, or execute arbitrarycode with the permissions of the user running the JRE. (CVE-2008-1187)Please note: This vulnerability can only be triggered in java-1.4.2-bea bycalling the "appletviewer" application.All java-1.4.2-bea users should upgrade to this updated package whichaddresses this vulnerability.

Solution(s)

  • redhat-upgrade-java-1-4-2-bea
  • redhat-upgrade-java-1-4-2-bea-demo
  • redhat-upgrade-java-1-4-2-bea-devel
  • redhat-upgrade-java-1-4-2-bea-jdbc
  • redhat-upgrade-java-1-4-2-bea-missioncontrol
  • redhat-upgrade-java-1-4-2-bea-src

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;