Vulnerability & Exploit Database

Back to search

RHSA-2008:0715: nss_ldap security and bug fix update

Severity CVSS Published Added Modified
4 (AV:N/AC:M/Au:N/C:P/I:N/A:N) November 13, 2007 July 30, 2008 July 04, 2017

Description

The nss_ldap package contains the nss_ldap and pam_ldap modules. Thenss_ldap module is a plug-in which allows applications to retrieveinformation about users and groups from a directory server. The pam_ldapmodule allows PAM-aware applications to use a directory server to verifyuser passwords.A race condition was discovered in nss_ldap, which affected certainapplications that make LDAP connections, such as Dovecot. This could causenss_ldap to answer a request for information about one user with theinformation about a different user. (CVE-2007-5794)As well, this updated package fixes the following bugs:LDAP password information update failed: Can't contact LDAP serverInsufficient 'write' privilege to the 'userPassword' attribute of entry[entry]In this updated package, password changes are allowed when binding againsta slave server, which resolves this issue.As well, this updated package upgrades nss_ldap to the version as shippedwith Red Hat Enterprise Linux 5.Users of nss_ldap are advised to upgrade to this updated package, whichresolves these issues.

Scan For This Vulnerability

Use our top-rated tool to discover, prioritize, and remediate your vulnerabilities

 Free InsightVM Trial

References

Solution

redhat-upgrade-nss_ldap

Related Vulnerabilities