Vulnerability & Exploit Database

Back to search

RHSA-2009:0004: openssl security update

Severity CVSS Published Added Modified
6 (AV:N/AC:M/Au:N/C:N/I:P/A:P) January 07, 2009 February 22, 2009 July 04, 2017

Description

OpenSSL is a toolkit that implements Secure Sockets Layer (SSL v2/v3) andTransport Layer Security (TLS v1) protocols as well as a full-strength,general purpose, cryptography library.The Google security team discovered a flaw in the way OpenSSL checked theverification of certificates. An attacker in control of a malicious server,or able to effect a "man in the middle" attack, could present a malformedSSL/TLS signature from a certificate chain to a vulnerable client andbypass validation. (CVE-2008-5077)All OpenSSL users should upgrade to these updated packages, which containbackported patches to resolve these issues. For the update to take effect,all running OpenSSL client applications must be restarted, or the systemrebooted.

Scan For This Vulnerability

Use our top-rated tool to discover, prioritize, and remediate your vulnerabilities

 Free InsightVM Trial

References

Solution

redhat-upgrade-openssl

Related Vulnerabilities