Rapid7 Vulnerability & Exploit Database

RHSA-2010:0505: perl-Archive-Tar security update

Back to Search

RHSA-2010:0505: perl-Archive-Tar security update

Severity
7
CVSS
(AV:N/AC:M/Au:N/C:P/I:P/A:P)
Published
11/02/2007
Created
07/25/2018
Added
07/16/2010
Modified
07/04/2017

Description

The Archive::Tar module provides a mechanism for Perl scripts to manipulatetar archive files.Multiple directory traversal flaws were discovered in the Archive::Tarmodule. A specially-crafted tar file could cause a Perl script, using theArchive::Tar module to extract the archive, to overwrite an arbitrary filewritable by the user running the script. (CVE-2007-4829)This package upgrades the Archive::Tar module to version 1.39_01. Refer tothe Archive::Tar module's changes file, linked to in the References, for afull list of changes.Users of perl-Archive-Tar are advised to upgrade to this updated package,which corrects these issues. All applications using the Archive::Tar modulemust be restarted for this update to take effect.

Solution(s)

  • redhat-upgrade-perl-archive-tar

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;