Rapid7 Vulnerability & Exploit Database

RHSA-2010:0518: scsi-target-utils security update

Back to Search

RHSA-2010:0518: scsi-target-utils security update

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:N/I:N/A:P)
Published
07/08/2010
Created
07/25/2018
Added
07/16/2010
Modified
07/04/2017

Description

The scsi-target-utils package contains the daemon and tools to set up andmonitor SCSI targets. Currently, iSCSI software and iSER targets aresupported.Multiple buffer overflow flaws were found in scsi-target-utils' tgtddaemon. A remote attacker could trigger these flaws by sending acarefully-crafted Internet Storage Name Service (iSNS) request, causing thetgtd daemon to crash. (CVE-2010-2221)Red Hat would like to thank the Vulnerability Research Team at TELUSSecurity Labs and Fujita Tomonori for responsibly reporting these flaws.All scsi-target-utils users should upgrade to this updated package, whichcontains a backported patch to correct these issues. All runningscsi-target-utils services must be restarted for the update to take effect.

Solution(s)

  • redhat-upgrade-scsi-target-utils

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;