Rapid7 Vulnerability & Exploit Database

RHSA-2011:1154: libXfont security update

Back to Search

RHSA-2011:1154: libXfont security update

Severity
9
CVSS
(AV:N/AC:M/Au:N/C:C/I:C/A:C)
Published
08/19/2011
Created
07/25/2018
Added
08/19/2011
Modified
07/04/2017

Description

The libXfont packages provide the X.Org libXfont runtime library. X.Org isan open source implementation of the X Window System.A buffer overflow flaw was found in the way the libXfont library, used bythe X.Org server, handled malformed font files compressed using UNIXcompress. A malicious, local user could exploit this issue to potentiallyexecute arbitrary code with the privileges of the X.Org server.(CVE-2011-2895)Users of libXfont should upgrade to these updated packages, which contain abackported patch to resolve this issue. All running X.Org server instancesmust be restarted for the update to take effect.

Solution(s)

  • redhat-upgrade-libxfont
  • redhat-upgrade-libxfont-debuginfo
  • redhat-upgrade-libxfont-devel

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;