Rapid7 Vulnerability & Exploit Database

RHSA-2013:1100: qemu-kvm security update

Back to Search

RHSA-2013:1100: qemu-kvm security update

Severity
7
CVSS
(AV:L/AC:L/Au:N/C:C/I:C/A:C)
Published
07/22/2013
Created
07/25/2018
Added
07/24/2013
Modified
07/04/2017

Description

KVM (Kernel-based Virtual Machine) is a full virtualization solution forLinux on AMD64 and Intel 64 systems. qemu-kvm is the user-space componentfor running virtual machines using KVM.An unquoted search path flaw was found in the way the QEMU Guest Agentservice installation was performed on Windows. Depending on the permissionsof the directories in the unquoted search path, a local, unprivileged usercould use this flaw to have a binary of their choosing executed with SYSTEMprivileges. (CVE-2013-2231)This issue was discovered by Lev Veyde of Red Hat.All users of qemu-kvm should upgrade to these updated packages, whichcontain backported patches to correct this issue. After installing thisupdate, shut down all running virtual machines. Once all virtual machineshave shut down, start them again for this update to take effect.

Solution(s)

  • redhat-upgrade-qemu-guest-agent
  • redhat-upgrade-qemu-guest-agent-win32
  • redhat-upgrade-qemu-img
  • redhat-upgrade-qemu-kvm
  • redhat-upgrade-qemu-kvm-debuginfo
  • redhat-upgrade-qemu-kvm-tools

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;