Vulnerability & Exploit Database

Back to search

RHSA-2015:2594: libpng security update

Severity CVSS Published Added Modified
8 (AV:N/AC:L/Au:N/C:P/I:P/A:P) November 12, 2015 December 11, 2015 March 21, 2018

Description

The libpng packages contain a library of functions for creating andmanipulating PNG (Portable Network Graphics) image format files.It was discovered that the png_get_PLTE() and png_set_PLTE() functions oflibpng did not correctly calculate the maximum palette sizes for bit depthsof less than 8. In case an application tried to use these functions incombination with properly calculated palette sizes, this could lead to abuffer overflow or out-of-bounds reads. An attacker could exploit this tocause a crash or potentially execute arbitrary code by tricking anunsuspecting user into processing a specially crafted PNG image. However,the exact impact is dependent on the application using the library.(CVE-2015-8126, CVE-2015-8472)An array-indexing error was discovered in the png_convert_to_rfc1123()function of libpng. An attacker could possibly use this flaw to cause anout-of-bounds read by tricking an unsuspecting user into processing aspecially crafted PNG image. (CVE-2015-7981)All libpng users are advised to upgrade to these updated packages, whichcontain backported patches to correct these issues.

Scan For This Vulnerability

Use our top-rated tool to discover, prioritize, and remediate your vulnerabilities

 Free InsightVM Trial

References

Solution

redhat-upgrade-libpng

Related Vulnerabilities