Rapid7 Vulnerability & Exploit Database

Mozilla Firefox Javascript Privilege Escalation Vulnerability

Back to Search

Mozilla Firefox Javascript Privilege Escalation Vulnerability

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
05/12/2005
Created
07/25/2018
Added
07/25/2005
Modified
02/13/2015

Description

Firefox before 1.0.4 and Mozilla Suite before 1.7.8 do not properly limit privileges of Javascript eval and Script objects in the calling context, which allows remote attackers to conduct unauthorized activities via "non-DOM property overrides," a variant of CVE-2005-1160.

Solution(s)

  • mozilla-firefox-upgrade-1_0_4
  • mozilla-firefox-upgrade-latest

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;