Rapid7 Vulnerability & Exploit Database

MongoDB: Unspecified Security Vulnerability (CVE-2018-20802)

Back to Search

MongoDB: Unspecified Security Vulnerability (CVE-2018-20802)

Severity
4
CVSS
(AV:N/AC:L/Au:S/C:N/I:N/A:P)
Published
11/23/2020
Created
12/02/2020
Added
12/01/2020
Modified
12/01/2020

Description

A user authorized to perform database queries may trigger denial of service by issuing specially crafted queries with compound indexes affecting QueryPlanner. This issue affects: MongoDB Inc. MongoDB Server v3.6 versions prior to 3.6.9, v4.0 versions prior to 4.0.3.

Solution(s)

  • mongodb-upgrade-3_6_9
  • mongodb-upgrade-4_0_3

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;