Rapid7 Vulnerability & Exploit Database

MongoDB: Improper Input Validation (CVE-2019-2389)

Back to Search

MongoDB: Improper Input Validation (CVE-2019-2389)

Severity
2
CVSS
(AV:L/AC:M/Au:N/C:N/I:N/A:P)
Published
08/30/2019
Created
11/13/2019
Added
10/31/2019
Modified
11/13/2019

Description

Incorrect scoping of kill operations in MongoDB Server's packaged SysV init scripts allow users with write access to the PID file to insert arbitrary PIDs to be killed when the root user stops the MongoDB process via SysV init. This issue affects: MongoDB Inc. MongoDB Server v4.0 versions prior to 4.0.11; v3.6 versions prior to 3.6.14; v3.4 versions prior to 3.4.22.

Solution(s)

  • mongodb-upgrade-3_4_22
  • mongodb-upgrade-3_6_14
  • mongodb-upgrade-4_0_11

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;