Rapid7 Vulnerability & Exploit Database

Mozilla security issue: Cross-domain exploit on zombie document with event handlers

Back to Search

Mozilla security issue: Cross-domain exploit on zombie document with event handlers

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:P/I:N/A:N)
Published
12/03/2003
Created
07/25/2018
Added
01/06/2005
Modified
07/22/2012

Description

The system is running a vulnerable version of the Mozilla browser. During page transition it was possible to run event handlers from the old page in the context of the new page. This has been demonstrated to allow cookie stealing, and potentially any sensitive account information displayed by the new site.

Solution(s)

  • mozilla-firefox-upgrade-latest

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;