Rapid7 Vulnerability & Exploit Database

Oracle Solaris 11: CVE-2017-1000115: Vulnerability in Mercurial, Mercurial source code management

Back to Search

Oracle Solaris 11: CVE-2017-1000115: Vulnerability in Mercurial, Mercurial source code management

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:N/I:P/A:N)
Published
09/19/2017
Created
07/25/2018
Added
09/19/2017
Modified
11/17/2021

Description

Mercurial prior to version 4.3 is vulnerable to a missing symlink check that can malicious repositories to modify files outside the repository

Solution(s)

  • oracle-solaris-11-3-upgrade-value-developer-versioning-mercurial-27-4-1-3-0-175-3-24-0-2-0
  • oracle-solaris-11-3-upgrade-value-developer-versioning-mercurial-4-1-3-0-175-3-24-0-2-0
  • oracle-solaris-11-4-upgrade-value-developer-versioning-mercurial-27-4-7-1-11-4-7-0-1-3-0
  • oracle-solaris-11-4-upgrade-value-developer-versioning-mercurial-4-7-1-11-4-7-0-1-3-0

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;