Rapid7 Vulnerability & Exploit Database

Oracle Linux: CVE-2010-0742: ELSA-2016-3558 - openssl security update

Back to Search

Oracle Linux: CVE-2010-0742: ELSA-2016-3558 - openssl security update

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
06/03/2010
Created
07/25/2018
Added
05/13/2016
Modified
04/11/2019

Description

The Cryptographic Message Syntax (CMS) implementation in crypto/cms/cms_asn1.c in OpenSSL before 0.9.8o and 1.x before 1.0.0a does not properly handle structures that contain OriginatorInfo, which allows context-dependent attackers to modify invalid memory locations or conduct double-free attacks, and possibly execute arbitrary code, via unspecified vectors.

Solution(s)

  • oracle-linux-upgrade-openssl
  • oracle-linux-upgrade-openssl-devel
  • oracle-linux-upgrade-openssl-perl
  • oracle-linux-upgrade-openssl-static

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;