Rapid7 Vulnerability & Exploit Database

Oracle Linux: (CVE-2019-11253) ELSA-2019-4816: kubernetes security update

Back to Search

Oracle Linux: (CVE-2019-11253) ELSA-2019-4816: kubernetes security update

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:N/I:N/A:P)
Published
10/17/2019
Created
02/04/2020
Added
02/01/2020
Modified
02/01/2020

Description

Improper input validation in the Kubernetes API server in versions v1.0-1.12 and versions prior to v1.13.12, v1.14.8, v1.15.5, and v1.16.2 allows authorized users to send malicious YAML or JSON payloads, causing the API server to consume excessive CPU or memory, potentially crashing and becoming unavailable. Prior to v1.14.0, default RBAC policy authorized anonymous users to submit requests that could trigger this vulnerability. Clusters upgraded from a version prior to v1.14.0 keep the more permissive policy by default for backwards compatibility.

Solution(s)

  • oracle-linux-upgrade-kubeadm
  • oracle-linux-upgrade-kubeadm-ha-setup
  • oracle-linux-upgrade-kubeadm-upgrade
  • oracle-linux-upgrade-kubectl
  • oracle-linux-upgrade-kubelet
  • oracle-linux-upgrade-kubernetes

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;