Rapid7 Vulnerability & Exploit Database

Oracle Linux: (CVE-2022-48338) ELSA-2023-2626: emacs security update

Free InsightVM Trial No Credit Card Necessary
2024 Attack Intel Report Latest research by Rapid7 Labs
Back to Search

Oracle Linux: (CVE-2022-48338) ELSA-2023-2626: emacs security update

Severity
4
CVSS
(AV:L/AC:M/Au:N/C:P/I:P/A:P)
Published
02/20/2023
Created
05/18/2023
Added
05/17/2023
Modified
05/17/2023

Description

An issue was discovered in GNU Emacs through 28.2. In ruby-mode.el, the ruby-find-library-file function has a local command injection vulnerability. The ruby-find-library-file function is an interactive function, and bound to C-c C-f. Inside the function, the external command gem is called through shell-command-to-string, but the feature-name parameters are not escaped. Thus, malicious Ruby source files may cause commands to be executed.

Solution(s)

  • oracle-linux-upgrade-emacs
  • oracle-linux-upgrade-emacs-common
  • oracle-linux-upgrade-emacs-filesystem
  • oracle-linux-upgrade-emacs-lucid
  • oracle-linux-upgrade-emacs-nox

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;