Rapid7 Vulnerability & Exploit Database

pfSense: pfSense-SA-16_01.webgui: Arbitrary Code Execution

Back to Search

pfSense: pfSense-SA-16_01.webgui: Arbitrary Code Execution

Severity
9
CVSS
(AV:N/AC:L/Au:S/C:C/I:C/A:C)
Published
04/01/2016
Created
07/25/2018
Added
08/25/2017
Modified
05/07/2018

Description

pfSense before 2.3 allows remote authenticated users to execute arbitrary OS commands via a '|' character in the status_rrd_graph_img.php graph parameter, related to _rrd_graph_img.php.

Solution(s)

  • pfsense-upgrade-latest

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;