Rapid7 Vulnerability & Exploit Database

PHP Vulnerability: CVE-2007-1581

Back to Search

PHP Vulnerability: CVE-2007-1581

Severity
9
CVSS
(AV:N/AC:M/Au:N/C:C/I:C/A:C)
Published
03/21/2007
Created
07/25/2018
Added
10/01/2012
Modified
07/21/2021

Description

The resource system in PHP 5.0.0 through 5.2.1 allows context-dependent attackers to execute arbitrary code by interrupting the hash_update_file function via a userspace (1) error or (2) stream handler, which can then be used to destroy and modify internal resources. NOTE: it was later reported that PHP 5.2 through 5.2.13 and 5.3 through 5.3.2 are also affected.

Solution(s)

  • php-upgrade-5_2_14
  • php-upgrade-5_3_2

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;