Rapid7 Vulnerability & Exploit Database

PHP Vulnerability: CVE-2007-3007

Back to Search

PHP Vulnerability: CVE-2007-3007

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:P/I:N/A:N)
Published
06/04/2007
Created
07/25/2018
Added
10/01/2012
Modified
09/01/2022

Description

PHP 5 before 5.2.3 does not enforce the open_basedir or safe_mode restriction in certain cases, which allows context-dependent attackers to determine the existence of arbitrary files by checking if the readfile function returns a string. NOTE: this issue might also involve the realpath function.

Solution(s)

  • php-upgrade-5_2_3

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;