Rapid7 Vulnerability & Exploit Database

PHP Vulnerability: CVE-2010-2531

Back to Search

PHP Vulnerability: CVE-2010-2531

Severity
4
CVSS
(AV:N/AC:M/Au:N/C:P/I:N/A:N)
Published
08/20/2010
Created
07/25/2018
Added
10/01/2012
Modified
07/21/2021

Description

The var_export function in PHP 5.2 before 5.2.14 and 5.3 before 5.3.3 flushes the output buffer to the user when certain fatal errors occur, even if display_errors is off, which allows remote attackers to obtain sensitive information by causing the application to exceed limits for memory, execution time, or recursion.

Solution(s)

  • php-upgrade-5_2_14
  • php-upgrade-5_3_3

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;