Rapid7 Vulnerability & Exploit Database

PHP Vulnerability: CVE-2019-9637

Back to Search

PHP Vulnerability: CVE-2019-9637

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:P/I:N/A:N)
Published
03/08/2019
Created
03/19/2019
Added
03/12/2019
Modified
07/21/2021

Description

An issue was discovered in PHP before 7.1.27, 7.2.x before 7.2.16, and 7.3.x before 7.3.3. Due to the way rename() across filesystems is implemented, it is possible that file being renamed is briefly available with wrong permissions while the rename is ongoing, thus enabling unauthorized users to access the data.

Solution(s)

  • php-upgrade-7_1_27
  • php-upgrade-7_2_16
  • php-upgrade-7_3_3

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;