Rapid7 Vulnerability & Exploit Database

PostgreSQL class C vulnerability in core server: CVE-2009-3230

Back to Search

PostgreSQL class C vulnerability in core server: CVE-2009-3230

Severity
7
CVSS
(AV:N/AC:L/Au:S/C:P/I:P/A:P)
Published
09/17/2009
Created
07/25/2018
Added
02/24/2013
Modified
02/13/2015

Description

The core server component in PostgreSQL 8.4 before 8.4.1, 8.3 before 8.3.8, 8.2 before 8.2.14, 8.1 before 8.1.18, 8.0 before 8.0.22, and 7.4 before 7.4.26 does not use the appropriate privileges for the (1) RESET ROLE and (2) RESET SESSION AUTHORIZATION operations, which allows remote authenticated users to gain privileges. NOTE: this is due to an incomplete fix for CVE-2007-6600.

Solution(s)

  • postgres-upgrade-7_4_26
  • postgres-upgrade-8_0_22
  • postgres-upgrade-8_1_18
  • postgres-upgrade-8_2_14
  • postgres-upgrade-8_3_8
  • postgres-upgrade-8_4_1

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;