Rapid7 Vulnerability & Exploit Database

Postgres Multi-byte Encoding SQL Injection Vulnerability

Back to Search

Postgres Multi-byte Encoding SQL Injection Vulnerability

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
05/24/2006
Created
07/25/2018
Added
06/01/2006
Modified
05/27/2016

Description

Logicalware MailManager before 2.0.10 does not remove 0xc8 0x27 (0xc8 followed by a single-quote character) from the data stream to the server, which allows remote attackers to modify data and gain administrative access when PostgreSQL is used, aka "bug #1494281 - Postgres encoding security hole." NOTE: while this issue involves PostgreSQL, it is specific to MailManager's interface to PostgreSQL and is therefore a different vulnerability than CVE-2006-2313 and CVE-2006-2314.

Solution(s)

  • postgres-upgrade-7_3_15
  • postgres-upgrade-7_4_7
  • postgres-upgrade-8_0_8
  • postgres-upgrade-8_1_4

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;