Rapid7 Vulnerability & Exploit Database

Pulse Secure Pulse Connect Secure: CVE-2012-2131: Pulse Connect Secure and Pulse Policy Secure Multiple OpenSSL vulnerabilities (JSA10591)

Back to Search

Pulse Secure Pulse Connect Secure: CVE-2012-2131: Pulse Connect Secure and Pulse Policy Secure Multiple OpenSSL vulnerabilities (JSA10591)

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
04/24/2012
Created
10/28/2020
Added
10/28/2020
Modified
10/28/2020

Description

Multiple integer signedness errors in crypto/buffer/buffer.c in OpenSSL 0.9.8v allow remote attackers to conduct buffer overflow attacks, and cause a denial of service (memory corruption) or possibly have unspecified other impact, via crafted DER data, as demonstrated by an X.509 certificate or an RSA public key. NOTE: this vulnerability exists because of an incomplete fix for CVE-2012-2110.

Solution(s)

  • pulse-secure-pulse-connect-secure-upgrade-7_1r15
  • pulse-secure-pulse-connect-secure-upgrade-7_2r11
  • pulse-secure-pulse-connect-secure-upgrade-7_3r6
  • pulse-secure-pulse-connect-secure-upgrade-7_4r3

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;