Rapid7 Vulnerability & Exploit Database

QuickTime: heap overflow allows arbitrary code exeuction via malicious MIDI files (CVE-2007-0712)

Back to Search

QuickTime: heap overflow allows arbitrary code exeuction via malicious MIDI files (CVE-2007-0712)

Severity
9
CVSS
(AV:N/AC:M/Au:N/C:C/I:C/A:C)
Published
03/05/2007
Created
07/25/2018
Added
10/25/2010
Modified
01/30/2020

Description

A heap buffer overflow exists in QuickTime's handling of MIDI files. By enticing a user to open a malicious MIDI file, an attacker can trigger the overflow, which may lead to an application crash or arbitrary code execution. This update addresses the issue by performing additional validation of MIDI files. Credit to Mike Price of McAfee AVERT Labs for reporting this issue.

Solution(s)

  • quicktime-upgrade-7_1_5

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;