Rapid7 Vulnerability & Exploit Database

Red Hat JBoss EAP: Unspecified Security Vulnerability (CVE-2019-14820)

Back to Search

Red Hat JBoss EAP: Unspecified Security Vulnerability (CVE-2019-14820)

Severity
4
CVSS
(AV:N/AC:L/Au:S/C:P/I:N/A:N)
Published
01/08/2020
Created
02/12/2020
Added
02/11/2020
Modified
11/26/2021

Description

It was found that keycloak before version 8.0.0 exposes internal adapter endpoints in org.keycloak.constants.AdapterConstants, which can be invoked via a specially-crafted URL. This vulnerability could allow an attacker to access unauthorized information.

Solution(s)

  • red-hat-jboss-eap-upgrade-7_3_4

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;