Rapid7 Vulnerability & Exploit Database

Red Hat: CVE-2020-36328: Important: libwebp security update (Multiple Advisories)

Back to Search

Red Hat: CVE-2020-36328: Important: libwebp security update (Multiple Advisories)

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
05/21/2021
Created
06/09/2021
Added
06/08/2021
Modified
06/14/2021

Description

A flaw was found in libwebp in versions before 1.0.1. A heap-based buffer overflow in function WebPDecodeRGBInto is possible due to an invalid check for buffer size. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

Solution(s)

  • redhat-upgrade-libwebp
  • redhat-upgrade-libwebp-debuginfo
  • redhat-upgrade-libwebp-debugsource
  • redhat-upgrade-libwebp-devel
  • redhat-upgrade-libwebp-java
  • redhat-upgrade-libwebp-java-debuginfo
  • redhat-upgrade-libwebp-tools
  • redhat-upgrade-libwebp-tools-debuginfo
  • redhat-upgrade-qt5-qtimageformats
  • redhat-upgrade-qt5-qtimageformats-debuginfo
  • redhat-upgrade-qt5-qtimageformats-doc

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;