Rapid7 Vulnerability & Exploit Database

Rocky Linux: CVE-2021-22883: nodejs-14 (Multiple Advisories)

Free InsightVM Trial No Credit Card Necessary
2024 Attack Intel Report Latest research by Rapid7 Labs
Back to Search

Rocky Linux: CVE-2021-22883: nodejs-14 (Multiple Advisories)

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:N/I:N/A:C)
Published
03/03/2021
Created
03/13/2024
Added
03/12/2024
Modified
04/18/2024

Description

Node.js before 10.24.0, 12.21.0, 14.16.0, and 15.10.0 is vulnerable to a denial of service attack when too many connection attempts with an 'unknownProtocol' are established. This leads to a leak of file descriptors. If a file descriptor limit is configured on the system, then the server is unable to accept new connections and prevent the process also from opening, e.g. a file. If no file descriptor limit is configured, then this lead to an excessive memory usage and cause the system to run out of memory.

Solution(s)

  • rocky-upgrade-nodejs
  • rocky-upgrade-nodejs-debuginfo
  • rocky-upgrade-nodejs-debugsource
  • rocky-upgrade-nodejs-devel
  • rocky-upgrade-nodejs-docs
  • rocky-upgrade-nodejs-full-i18n
  • rocky-upgrade-nodejs-nodemon
  • rocky-upgrade-nodejs-packaging
  • rocky-upgrade-npm

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;