Rapid7 Vulnerability & Exploit Database

Rocky Linux: CVE-2021-22940: nodejs-14 (Multiple Advisories)

Free InsightVM Trial No Credit Card Necessary
2024 Attack Intel Report Latest research by Rapid7 Labs
Back to Search

Rocky Linux: CVE-2021-22940: nodejs-14 (Multiple Advisories)

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:N/I:P/A:N)
Published
08/16/2021
Created
03/13/2024
Added
03/12/2024
Modified
04/18/2024

Description

Node.js before 16.6.1, 14.17.5, and 12.22.5 is vulnerable to a use after free attack where an attacker might be able to exploit the memory corruption, to change process behavior.

Solution(s)

  • rocky-upgrade-nodejs
  • rocky-upgrade-nodejs-debuginfo
  • rocky-upgrade-nodejs-debugsource
  • rocky-upgrade-nodejs-devel
  • rocky-upgrade-nodejs-docs
  • rocky-upgrade-nodejs-full-i18n
  • rocky-upgrade-nodejs-nodemon
  • rocky-upgrade-nodejs-packaging
  • rocky-upgrade-npm

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;