Rapid7 Vulnerability & Exploit Database

Rocky Linux: CVE-2021-3580: Moderate: gnutls and nettle security, bug fix, and enhancement update (RLSA-2021-4451)

Back to Search

Rocky Linux: CVE-2021-3580: Moderate: gnutls and nettle security, bug fix, and enhancement update (RLSA-2021-4451)

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:N/I:N/A:P)
Published
08/05/2021
Created
09/02/2022
Added
09/02/2022
Modified
09/02/2022

Description

A flaw was found in the way nettle's RSA decryption functions handled specially crafted ciphertext. An attacker could use this flaw to provide a manipulated ciphertext leading to application crash and denial of service.

Solution(s)

  • rocky-upgrade-gnutls
  • rocky-upgrade-gnutls-c++
  • rocky-upgrade-gnutls-c++-debuginfo
  • rocky-upgrade-gnutls-dane
  • rocky-upgrade-gnutls-dane-debuginfo
  • rocky-upgrade-gnutls-debuginfo
  • rocky-upgrade-gnutls-debugsource
  • rocky-upgrade-gnutls-devel
  • rocky-upgrade-gnutls-utils
  • rocky-upgrade-gnutls-utils-debuginfo
  • rocky-upgrade-nettle
  • rocky-upgrade-nettle-debuginfo
  • rocky-upgrade-nettle-debugsource
  • rocky-upgrade-nettle-devel

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;