Rapid7 Vulnerability & Exploit Database

Rocky Linux: CVE-2022-35255: nodejs-18 (Multiple Advisories)

Free InsightVM Trial No Credit Card Necessary
2024 Attack Intel Report Latest research by Rapid7 Labs
Back to Search

Rocky Linux: CVE-2022-35255: nodejs-18 (Multiple Advisories)

Severity
4
CVSS
(AV:L/AC:M/Au:N/C:P/I:P/A:P)
Published
12/05/2022
Created
03/13/2024
Added
03/12/2024
Modified
05/06/2024

Description

A weak randomness in WebCrypto keygen vulnerability exists in Node.js 18 due to a change with EntropySource() in SecretKeyGenTraits::DoKeyGen() in src/crypto/crypto_keygen.cc. There are two problems with this: 1) It does not check the return value, it assumes EntropySource() always succeeds, but it can (and sometimes will) fail. 2) The random data returned byEntropySource() may not be cryptographically strong and therefore not suitable as keying material.

Solution(s)

  • rocky-upgrade-nodejs
  • rocky-upgrade-nodejs-debuginfo
  • rocky-upgrade-nodejs-debugsource
  • rocky-upgrade-nodejs-devel
  • rocky-upgrade-nodejs-docs
  • rocky-upgrade-nodejs-full-i18n
  • rocky-upgrade-nodejs-libs
  • rocky-upgrade-nodejs-libs-debuginfo
  • rocky-upgrade-nodejs-nodemon
  • rocky-upgrade-nodejs-packaging
  • rocky-upgrade-nodejs-packaging-bundler
  • rocky-upgrade-npm

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;