Rapid7 Vulnerability & Exploit Database

Ruby on Rails: Unspecified Security Vulnerability (CVE-2023-22792)

Free InsightVM Trial No Credit Card Necessary
Watch Demo See how it all works
Back to Search

Ruby on Rails: Unspecified Security Vulnerability (CVE-2023-22792)

Severity
4
CVSS
(AV:L/AC:M/Au:N/C:P/I:P/A:P)
Published
02/09/2023
Created
02/22/2023
Added
02/21/2023
Modified
02/05/2024

Description

A regular expression based DoS vulnerability in Action Dispatch <6.0.6.1,< 6.1.7.1, and <7.0.4.1. Specially crafted cookies, in combination with a specially crafted X_FORWARDED_HOST header can cause the regular expression engine to enter a state of catastrophic backtracking. This can cause the process to use large amounts of CPU and memory, leading to a possible DoS vulnerability All users running an affected release should either upgrade or use one of the workarounds immediately.

Solution(s)

  • ruby-on-rails-upgrade-6_0_6_1
  • ruby-on-rails-upgrade-6_1_7_1
  • ruby-on-rails-upgrade-7_0_4_1

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;