Rapid7 Vulnerability & Exploit Database

SAP Netweaver: CVE-2021-21481: Missing Authorization Check in SAP NetWeaver AS JAVA (MigrationService)

Back to Search

SAP Netweaver: CVE-2021-21481: Missing Authorization Check in SAP NetWeaver AS JAVA (MigrationService)

Severity
10
CVSS
(AV:A/AC:L/Au:N/C:C/I:C/A:C)
Published
03/09/2021
Created
04/30/2021
Added
04/29/2021
Modified
04/29/2021

Description

The MigrationService, which is part of SAP NetWeaver, does not perform an authorization check. This might allow an unauthorized attacker to access configuration objects, including such that grant administrative privileges. This could result in complete compromise of system confidentiality, integrity, and availability.

Solution(s)

  • sap-netweaver-as-java-upgrade-latest

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;