Vulnerability & Exploit Database

Back to search

Apache Struts: S2-021 (CVE-2014-0112): Security updates available for Apache Struts

Severity CVSS Published Added Modified
8 (AV:N/AC:L/Au:N/C:P/I:P/A:P) April 29, 2014 June 27, 2017 January 25, 2018

Available Exploits 

Description

ParametersInterceptor in Apache Struts before 2.3.16.2 does not properly restrict access to the getClass method, which allows remote attackers to "manipulate" the ClassLoader and execute arbitrary code via a crafted request. NOTE: this vulnerability exists because of an incomplete fix for CVE-2014-0094.

Scan For This Vulnerability

Use our top-rated tool to discover, prioritize, and remediate your vulnerabilities

 Free InsightVM Trial

References

Solution

apache-struts-upgrade-2_3_16_2

Related Vulnerabilities