Rapid7 Vulnerability & Exploit Database

Apache Struts: S2-051 (CVE-2017-9793): Security updates available for Apache Struts

Back to Search

Apache Struts: S2-051 (CVE-2017-9793): Security updates available for Apache Struts

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:N/I:N/A:P)
Published
09/05/2017
Created
07/25/2018
Added
09/06/2017
Modified
08/14/2019

Description

The REST Plugin in Apache Struts 2.1.x, 2.3.7 through 2.3.33 and 2.5 through 2.5.12 is using an outdated XStream library which is vulnerable and allow perform a DoS attack using malicious request with specially crafted XML payload.

Solution(s)

  • apache-struts-upgrade-2_3_34
  • apache-struts-upgrade-2_5_13

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;