Rapid7 Vulnerability & Exploit Database

SUSE Linux Security Vulnerability: CVE-2006-2024

Back to Search

SUSE Linux Security Vulnerability: CVE-2006-2024

Severity
4
CVSS
(AV:N/AC:L/Au:S/C:N/I:N/A:P)
Published
04/25/2006
Created
07/25/2018
Added
02/17/2015
Modified
07/04/2017

Description

Multiple vulnerabilities in libtiff before 3.8.1 allow context-dependent attackers to cause a denial of service via a TIFF image that triggers errors in (1) the TIFFFetchAnyArray function in (a) tif_dirread.c; (2) certain "codec cleanup methods" in (b) tif_lzw.c, (c) tif_pixarlog.c, and (d) tif_zip.c; (3) and improper restoration of setfield and getfield methods in cleanup functions within (e) tif_jpeg.c, tif_pixarlog.c, (f) tif_fax3.c, and tif_zip.c.

Solution(s)

  • suse-upgrade-libtiff
  • suse-upgrade-libtiff-32bit
  • suse-upgrade-libtiff-64bit
  • suse-upgrade-libtiff-x86

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;