Rapid7 Vulnerability & Exploit Database

SUSE Linux Security Vulnerability: CVE-2007-0104

Back to Search

SUSE Linux Security Vulnerability: CVE-2007-0104

Severity
7
CVSS
(AV:N/AC:M/Au:N/C:P/I:P/A:P)
Published
01/08/2007
Created
07/25/2018
Added
02/17/2015
Modified
07/04/2017

Description

The Adobe PDF specification 1.3, as implemented by (a) xpdf 3.0.1 patch 2, (b) kpdf in KDE before 3.5.5, (c) poppler before 0.5.4, and other products, allows remote attackers to have an unknown impact, possibly including denial of service (infinite loop), arbitrary code execution, or memory corruption, via a PDF file with a (1) crafted catalog dictionary or (2) a crafted Pages attribute that references an invalid page tree node.

Solution(s)

  • suse-upgrade-cups
  • suse-upgrade-cups-client
  • suse-upgrade-cups-devel
  • suse-upgrade-cups-libs
  • suse-upgrade-cups-libs-32bit
  • suse-upgrade-cups-libs-64bit
  • suse-upgrade-cups-libs-x86
  • suse-upgrade-gpdf
  • suse-upgrade-kdegraphics3-pdf
  • suse-upgrade-koffice-wordprocessing
  • suse-upgrade-poppler
  • suse-upgrade-poppler-devel
  • suse-upgrade-suse-release
  • suse-upgrade-xpdf
  • suse-upgrade-xpdf-tools

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;