Rapid7 Vulnerability & Exploit Database

SUSE Linux Security Vulnerability: CVE-2007-5197

Back to Search

SUSE Linux Security Vulnerability: CVE-2007-5197

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
11/02/2007
Created
07/25/2018
Added
02/17/2015
Modified
07/04/2017

Description

Buffer overflow in the Mono.Math.BigInteger class in Mono 1.2.5.1 and earlier allows context-dependent attackers to execute arbitrary code via unspecified vectors related to Reduce in Montgomery-based Pow methods.

Solution(s)

  • suse-upgrade-bytefx-data-mysql
  • suse-upgrade-ibm-data-db2
  • suse-upgrade-mono-basic
  • suse-upgrade-mono-core
  • suse-upgrade-mono-core-32bit
  • suse-upgrade-mono-data
  • suse-upgrade-mono-data-firebird
  • suse-upgrade-mono-data-oracle
  • suse-upgrade-mono-data-postgresql
  • suse-upgrade-mono-data-sqlite
  • suse-upgrade-mono-data-sybase
  • suse-upgrade-mono-devel
  • suse-upgrade-mono-extras
  • suse-upgrade-mono-jscript
  • suse-upgrade-mono-locale-extras
  • suse-upgrade-mono-nunit
  • suse-upgrade-mono-web
  • suse-upgrade-mono-winforms
  • suse-upgrade-suse-release

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;