Rapid7 Vulnerability & Exploit Database

SUSE Linux Security Vulnerability: CVE-2007-5393

Back to Search

SUSE Linux Security Vulnerability: CVE-2007-5393

Severity
9
CVSS
(AV:N/AC:M/Au:N/C:C/I:C/A:C)
Published
11/07/2007
Created
07/25/2018
Added
02/17/2015
Modified
07/04/2017

Description

Heap-based buffer overflow in the CCITTFaxStream::lookChar method in xpdf/Stream.cc in Xpdf 3.02p11 allows remote attackers to execute arbitrary code via a PDF file that contains a crafted CCITTFaxDecode filter.

Solution(s)

  • suse-upgrade-cups
  • suse-upgrade-cups-client
  • suse-upgrade-cups-devel
  • suse-upgrade-cups-libs
  • suse-upgrade-cups-libs-32bit
  • suse-upgrade-cups-libs-64bit
  • suse-upgrade-cups-libs-x86
  • suse-upgrade-gpdf
  • suse-upgrade-kdegraphics3-pdf
  • suse-upgrade-koffice
  • suse-upgrade-koffice-database
  • suse-upgrade-koffice-database-mysql
  • suse-upgrade-koffice-database-psql
  • suse-upgrade-koffice-devel
  • suse-upgrade-koffice-extra
  • suse-upgrade-koffice-illustration
  • suse-upgrade-koffice-planning
  • suse-upgrade-koffice-presentation
  • suse-upgrade-koffice-python
  • suse-upgrade-koffice-ruby
  • suse-upgrade-koffice-spreadsheet
  • suse-upgrade-koffice-wordprocessing
  • suse-upgrade-poppler
  • suse-upgrade-poppler-devel
  • suse-upgrade-poppler-doc
  • suse-upgrade-poppler-glib
  • suse-upgrade-poppler-qt
  • suse-upgrade-poppler-qt4
  • suse-upgrade-poppler-tools
  • suse-upgrade-suse-release
  • suse-upgrade-xpdf
  • suse-upgrade-xpdf-tools

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;