Rapid7 Vulnerability & Exploit Database

SUSE Linux Security Vulnerability: CVE-2008-1142

Back to Search

SUSE Linux Security Vulnerability: CVE-2008-1142

Severity
4
CVSS
(AV:L/AC:H/Au:N/C:P/I:P/A:P)
Published
04/07/2008
Created
07/25/2018
Added
02/17/2015
Modified
07/04/2017

Description

rxvt 2.6.4 opens a terminal window on :0 if the DISPLAY environment variable is not set, which might allow local users to hijack X11 connections. NOTE: it was later reported that rxvt-unicode, mrxvt, aterm, multi-aterm, and wterm are also affected. NOTE: realistic attack scenarios require that the victim enters a command on the wrong machine.

Solution(s)

  • suse-upgrade-rxvt-unicode
  • suse-upgrade-suse-release

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;