Rapid7 Vulnerability & Exploit Database

SUSE Linux Security Vulnerability: CVE-2008-4302

Back to Search

SUSE Linux Security Vulnerability: CVE-2008-4302

Severity
5
CVSS
(AV:L/AC:L/Au:N/C:N/I:N/A:C)
Published
09/29/2008
Created
07/25/2018
Added
02/17/2015
Modified
06/21/2018

Description

fs/splice.c in the splice subsystem in the Linux kernel before 2.6.22.2 does not properly handle a failure of the add_to_page_cache_lru function, and subsequently attempts to unlock a page that was not locked, which allows local users to cause a denial of service (kernel BUG and system crash), as demonstrated by the fio I/O tool.

Solution(s)

  • suse-upgrade-kernel-bigsmp
  • suse-upgrade-kernel-default
  • suse-upgrade-kernel-iseries64
  • suse-upgrade-kernel-kdump
  • suse-upgrade-kernel-ppc64
  • suse-upgrade-kernel-source
  • suse-upgrade-kernel-syms
  • suse-upgrade-kernel-xen
  • suse-upgrade-kernel-xenpae
  • suse-upgrade-suse-release

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;