Rapid7 Vulnerability & Exploit Database

SUSE Linux Security Vulnerability: CVE-2009-1955

Back to Search

SUSE Linux Security Vulnerability: CVE-2009-1955

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:N/I:N/A:P)
Published
06/07/2009
Created
07/25/2018
Added
02/17/2015
Modified
10/15/2020

Description

The expat XML parser in the apr_xml_* interface in xml/apr_xml.c in Apache APR-util before 1.3.7, as used in the mod_dav and mod_dav_svn modules in the Apache HTTP Server, allows remote attackers to cause a denial of service (memory consumption) via a crafted XML document containing a large number of nested entity references, as demonstrated by a PROPFIND request, a similar issue to CVE-2003-1564.

Solution(s)

  • suse-upgrade-apache2
  • suse-upgrade-apache2-devel
  • suse-upgrade-apache2-doc
  • suse-upgrade-apache2-example-pages
  • suse-upgrade-apache2-prefork
  • suse-upgrade-apache2-worker
  • suse-upgrade-libapr-util1
  • suse-upgrade-libapr-util1-64bit
  • suse-upgrade-libapr-util1-dbd-mysql
  • suse-upgrade-libapr-util1-dbd-pgsql
  • suse-upgrade-libapr-util1-dbd-sqlite3
  • suse-upgrade-libapr-util1-devel
  • suse-upgrade-libapr-util1-devel-64bit
  • suse-upgrade-libapr0

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;