Rapid7 Vulnerability & Exploit Database

SUSE Linux Security Vulnerability: CVE-2009-3608

Back to Search

SUSE Linux Security Vulnerability: CVE-2009-3608

Severity
9
CVSS
(AV:N/AC:M/Au:N/C:C/I:C/A:C)
Published
10/21/2009
Created
07/25/2018
Added
02/17/2015
Modified
07/04/2017

Description

Integer overflow in the ObjectStream::ObjectStream function in XRef.cc in Xpdf 3.x before 3.02pl4 and Poppler before 0.12.1, as used in GPdf, kdegraphics KPDF, CUPS pdftops, and teTeX, might allow remote attackers to execute arbitrary code via a crafted PDF document that triggers a heap-based buffer overflow.

Solution(s)

  • suse-upgrade-cups
  • suse-upgrade-cups-client
  • suse-upgrade-cups-devel
  • suse-upgrade-cups-libs
  • suse-upgrade-cups-libs-32bit
  • suse-upgrade-cups-libs-64bit
  • suse-upgrade-kdegraphics3-pdf
  • suse-upgrade-libpoppler-devel
  • suse-upgrade-libpoppler-doc
  • suse-upgrade-libpoppler-glib-devel
  • suse-upgrade-libpoppler-glib3
  • suse-upgrade-libpoppler-glib4
  • suse-upgrade-libpoppler-qt2
  • suse-upgrade-libpoppler-qt3-devel
  • suse-upgrade-libpoppler-qt4-3
  • suse-upgrade-libpoppler-qt4-devel
  • suse-upgrade-libpoppler3
  • suse-upgrade-libpoppler4
  • suse-upgrade-libpoppler5
  • suse-upgrade-poppler
  • suse-upgrade-poppler-devel
  • suse-upgrade-poppler-glib
  • suse-upgrade-poppler-qt
  • suse-upgrade-poppler-tools
  • suse-upgrade-sap-aio-release
  • suse-upgrade-xpdf
  • suse-upgrade-xpdf-tools

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;