Rapid7 Vulnerability & Exploit Database

SUSE Linux Security Vulnerability: CVE-2011-1091

Back to Search

SUSE Linux Security Vulnerability: CVE-2011-1091

Severity
4
CVSS
(AV:N/AC:L/Au:S/C:N/I:N/A:P)
Published
03/14/2011
Created
07/25/2018
Added
12/12/2013
Modified
07/04/2017

Description

libymsg.c in the Yahoo! protocol plugin in libpurple in Pidgin 2.6.0 through 2.7.10 allows (1) remote authenticated users to cause a denial of service (NULL pointer dereference and application crash) via a malformed YMSG notification packet, and allows (2) remote Yahoo! servers to cause a denial of service (NULL pointer dereference and application crash) via a malformed YMSG SMS message.

Solution(s)

  • suse-upgrade-finch
  • suse-upgrade-finch-devel
  • suse-upgrade-libpurple
  • suse-upgrade-libpurple-devel
  • suse-upgrade-libpurple-lang
  • suse-upgrade-libpurple-meanwhile
  • suse-upgrade-libpurple-mono
  • suse-upgrade-libpurple-tcl
  • suse-upgrade-pidgin
  • suse-upgrade-pidgin-devel
  • suse-upgrade-pidgin-evolution

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;