Rapid7 Vulnerability & Exploit Database

SUSE Linux Security Vulnerability: CVE-2011-1761

Back to Search

SUSE Linux Security Vulnerability: CVE-2011-1761

Severity
7
CVSS
(AV:N/AC:M/Au:N/C:P/I:P/A:P)
Published
06/07/2012
Created
07/25/2018
Added
02/17/2015
Modified
07/04/2017

Description

Multiple stack-based buffer overflows in the (1) abc_new_macro and (2) abc_new_umacro functions in src/load_abc.cpp in libmodplug before 0.8.8.3 allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted ABC file. NOTE: some of these details are obtained from third party information.

Solution(s)

  • suse-upgrade-libmodplug-devel
  • suse-upgrade-libmodplug0
  • suse-upgrade-libmodplug0-32bit

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;